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Copyright © Tektronix. All rights reserved. Licensed software products are owned by Tektronix or its subsidiaries or suppliers, and are
protected by national copyright laws and international treaty provisions.

Tektronix products are covered by U.S. and foreign patents, issued and pending. Information in this publication supersedes that in all
previously published material. Specifications and price change privileges reserved.

TEKTRONIX and TEK are registered trademarks of Tektronix, Inc.

Contacting Tektronix
Tektronix, Inc.
14150 SW Karl Braun Drive
P.O. Box 500
Beaverton, OR 97077
USA

For product information, sales, service, and technical support:
In North America, call 1-800-833-9200.
Worldwide, visit www.tektronix.com to find contacts in your area.

http://www.tektronix.com/contact


Warranty
Tektronix warrants that the media on which this software product is furnished and the encoding of the programs on the media will be
free from defects in materials and workmanship for a period of three (3) months from the date of shipment. If any such medium or
encoding proves defective during the warranty period, Tektronix will provide a replacement in exchange for the defective medium.
Except as to the media on which this software product is furnished, this software product is provided “as is” without warranty of any
kind, either express or implied. Tektronix does not warrant that the functions contained in this software product will meet Customer’s
requirements or that the operation of the programs will be uninterrupted or error-free.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the warranty
period. If Tektronix is unable to provide a replacement that is free from defects in materials and workmanship within a reasonable
time thereafter, Customer may terminate the license for this software product and return this software product and any associated
materials for credit or refund.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PRODUCT IN LIEU OF ANY OTHER WARRANTIES,
EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX’ RESPONSIBILITY TO REPLACE DEFECTIVE MEDIA OR REFUND
CUSTOMER’S PAYMENT IS THE SOLE AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF
THIS WARRANTY. TEKTRONIX AND ITS VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS ADVANCE NOTICE OF THE
POSSIBILITY OF SUCH DAMAGES.

[W9b – 15AUG04]



IMPORTANT

READ BEFORE OPERATING EQUIPMENT
This software is provided under license from Tektronix, Inc. Retention of this program for more than thirty (30) days or use of the
program in any manner constitutes acceptance of the license terms.

CAREFULLY READ THE ENCLOSED SOFTWARE LICENSE AGREEMENT. If you cannot agree to the license terms,
promptly contact the nearest Tektronix Field Office for return assistance.

TEKTRONIX SOFTWARE LICENSE AGREEMENT
THE PROGRAM, OR PROGRAMS, ENCODED OR INCORPORATED WITHIN EQUIPMENT, IS FURNISHED SUBJECT TO
THE TERMS AND CONDITIONS OF THIS AGREEMENT. RETENTION OF THE PROGRAM FOR MORE THAN THIRTY DAYS
OR USE OF THE PROGRAM IN ANY MANNER WILL BE CONSIDERED ACCEPTANCE OF THE AGREEMENT TERMS. IF
THESE TERMS ARE NOT ACCEPTABLE, THE UNUSED PROGRAM AND ANY ACCOMPANYING DOCUMENTATION SHOULD
BE RETURNED PROMPTLY TO TEKTRONIX FOR A FULL REFUND OF THE LICENSE FEE PAID. (FOR INFORMATION
REGARDING THE RETURN OF PROGRAMS ENCODED OR INCORPORATED WITHIN EQUIPMENT, CONTACT THE NEAREST
TEKTRONIX SALES OFFICE.)

DEFINITIONS. "Tektronix" means Tektronix, Inc., an Oregon corporation, or local Tektronix’ legal entity that is supplying the
equipment.

"Program" means the Tektronix software product (executable program and/or data) enclosed with this Agreement or included within the
equipment with which this Agreement is packed.

"Customer" means the person or organization in whose name the Program was ordered.

LICENSE. Customer may:

1. Use the Program on a single machine at any one time;

2. If the Program is provided in connection with a floating-user license, the Program may be used on multiple machines provided that
the user is authorized, and the total number of users at any one time does not exceed the total number of licensed concurrent users;

3. Modify the Program or merge it with another for use on the single machine; and

4. Copy the Program for archival or backup purposes, provided that no more than one (1) such copy is permitted to exist at any one
time. If the Program is provided in connection with a floating-user license, the Program may be copied onto multiple machines
for use by authorized users.

Each copy of the Program made by Customer must include a reproduction of any copyright notice or restrictive rights legend appearing
in or on the copy of the Program as received from Tektronix.

Customer may not:

1. Use the Program on more than one machine at any one time, unless covered by a floating-user license or separate site license;

2. Transfer the Program to any person or organization outside of Customer or the corporation of which Customer is a part without
the prior written consent of Tektronix, except in connection with the transfer of the equipment within which the programs are
encoded or incorporated;

3. Export or reexport, directly or indirectly, the program, any associated documentation, or the direct product thereof, to any country to
which such export or reexport is restricted by law or regulation of the United States or any foreign government having jurisdiction
without the prior authorization, if required, of the Office of Export Administration, Department of Commerce, Washington, D.C.
and the corresponding agency of such foreign government;



4. For object-code Programs only, reverse compile or disassemble the Program for any purpose; or

5. Copy the documentation accompanying the Program.

For Programs designed to reside on a single-machine and support one or more additional machines, either locally or remotely, without
permitting the Program to be transferred to an additional machine for local execution, the additional machines shall be considered
within the definition of "single machine". For programs permitting the Program to be transferred to an additional machine for local
execution, a separate license shall be required for each such machine with which the Program may be used, or each concurrent user
authorized under a floating-user license.

Title to the Program and all copies thereof, but not the media on which the Program or copies may reside, shall be and remain with
Tektronix or others for whom Tektronix has obtained a respective licensing right.

Customer shall pay when due all property taxes that may now or hereafter be imposed, levied or assessed with respect to the
possession or use of the Program or this license and shall file all reports required in connection with such taxes.

Any portion of the Program modified by Customer or merged with another program shall remain subject to these terms and conditions.

If the Program is acquired by or for an agency of the U.S. Government, the Program shall be considered computer software developed
at private expense and the license granted herein shall be interpreted as granting Customer restricted rights in the Program and related
documentation as defined in the applicable acquisition regulation.

THE PROGRAM MAY NOT BE USED, COPIED, MODIFIED, MERGED, OR TRANSFERRED TO ANOTHER EXCEPT AS
EXPRESSLY PERMITTED BY THESE TERMS AND CONDITIONS.

UPON TRANSFER OF ANY COPY, MODIFICATION, OR MERGED PORTION OF THE PROGRAM, THE LICENSE GRANTED
HEREIN IS AUTOMATICALLY TERMINATED.

TERM. The license granted herein is effective upon acceptance by Customer, and shall remain in effect until terminated as provided
herein. The license may be terminated by Customer at any time upon written notice to Tektronix. The license may be terminated
by Tektronix or any third party from whom Tektronix may have obtained a respective licensing right if Customer fails to comply with
any term or condition and such failure is not remedied within thirty (30) days after notice hereof from Tektronix or such third party.
Upon termination by either party, Customer shall return to Tektronix or destroy, the Program and all associated documentation,
together with all copies in any form.

LIMITED WARRANTY. Tektronix warrants that the media on which the Program is furnished and the encoding of the Program
on the media will be free from defects in materials and workmanship for a period of three (3) months from the date of shipment. If
any such medium or encoding proves defective during the warranty period, Tektronix will provide a replacement in exchange for the
defective medium. Except as to the media on which the Program is furnished, the Program is provided "as is" without warranty of
any kind, either express or implied. Tektronix does not warrant that the functions contained in the Program will meet Customer’s
requirements or that the operation of the Program will be uninterrupted or error-free.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the warranty period. If
Tektronix is unable to provide a replacement that is free from defects in materials and workmanship within a reasonable time thereafter,
Customer may terminate the license for the Program and return the Program and any associated materials for credit or refund.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PROGRAM IN LIEU OF ANY OTHER WARRANTIES,
EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX’ RESPONSIBILITY TO REPLACE DEFECTIVE MEDIA, OR REFUND
CUSTOMER’S PAYMENT IS THE SOLE AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS
WARRANTY.

LIMITATION OF LIABILITY, IN NO EVENT SHALL TEKTRONIX OR OTHERS FROM WHOM TEKTRONIX HAS OBTAINED A
LICENSING RIGHT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT
OF OR CONNECTED WITH CUSTOMER’S POSSESSION OR USE OF THE PROGRAM, EVEN IF TEKTRONIX OR SUCH
OTHERS HAS ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.



THIRD-PARTY DISCLAIMER. Except as expressly agreed otherwise, third parties from whom Tektronix may have obtained a
licensing right do not warrant the program, do not assume any liability with respect to its use, and do not undertake to furnish any
support or information relating thereto.

GENERAL. This Agreement contains the entire agreement between the parties with respect to the use, reproduction, and transfer of
the Program.

Neither this Agreement nor the license granted herein is assignable or transferable by Customer without the prior written consent
of Tektronix.

This Agreement and the license granted herein shall be governed by the laws of the state of Oregon.

All questions regarding this Agreement or the license granted herein should be directed to the nearest Tektronix Sales Office.
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Compliance Information

Compliance Information
This section lists the environmental standards with which the product complies.

Environmental Considerations
This section provides information about the environmental impact of the product.

Product End-of-Life Handling
Observe the following guidelines when recycling an instrument or component:

Equipment recycling. Production of this equipment required the extraction and use of natural resources. The equipment
may contain substances that could be harmful to the environment or human health if improperly handled at the product’s
end of life. To avoid release of such substances into the environment and to reduce the use of natural resources, we
encourage you to recycle this product in an appropriate system that will ensure that most of the materials are reused
or recycled appropriately.

This symbol indicates that this product complies with the applicable European Union requirements according
to Directives 2002/96/EC and 2006/66/EC on waste electrical and electronic equipment (WEEE) and
batteries. For information about recycling options, check the Support/Service section of the Tektronix Web
site (www.tektronix.com).

Restriction of Hazardous Substances
This product is classified as Monitoring and Control equipment, and is outside the scope of the 2002/95/EC RoHS Directive.

ii VQS1000 Quick Start User Manual



Preface

Preface
This manual describes the installation and use of the Tektronix VQS1000 Video Quality Software.

Key Features and Benefits
Video quality analysis software for single-ended QoE (Quality of Experience) analysis of video content

Available for installation on your own personal computer (PC)

Can be used with all Tektronix DTV monitoring probe configurations providing robust private backhauled video from the
monitoring probes

Multiple instances can be run per license to enable service comparison at different network locations (dependent on PC
processing power and video content type)

Triggered capture with pretrigger buffer enables archive of impairments or offline video quality analysis to be performed

QoE results are reflected in monitoring probe’s Remote User Interface and event log

Results available to management systems through DTV monitoring probes SNMP MIB

Automated round-robin polling sequentially checks services within an MPTS

NOTE. Polling is not applicable for offline file analysis.

Can be used standalone for offline file analysis, with support for MPTS and SPTS files, or for analyzing IP traffic from
a switch or router

Reliable and sophisticated analysis algorithms applied to decoded MPEG 2 or H.264 video to identify frozen, black,
macro-blocking and blocky compression artifacts. This enables operators to distinguish between impairments resulting
from network distribution versus artifacts resulting from over-compression.

Industry-first unique visualization tool with innovative impairment displays highlights the location and severity of video
defects enabling engineers to clearly see and validate the presence of impairments on the image.

Triggered-capture of streams and logging of live data enable offline analysis of service quality issues.

Applications
Affordable QoE Monitoring; live monitoring

Network performance optimization; in-service tuning of network

Network diagnostics; in service troubleshooting

VQS1000 Quick Start User Manual iii
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Product Documentation
The following table lists the product documentation supporting the VQS1000.

Table i: Product documentation
Item (Tektronix part number) Purpose Location
VQS1000 Quick Start User
Manual (077-0489-XX)

Provides installation and high-level
operational overviews
(this document)

VQS1000 Online Help –Printed
(077-0490-XX)

Provides in-depth operating information
in context-sensitive form

VQS1000 Release Notes
(077-0492-XX)

Describes late breaking product
information and operational issues

Related Products
MTM400A DTV Monitor
The MTM400A DTV Monitor provides a complete solution for multilayer, multichannel, remote monitoring to DVB, ATSC,
DCII, and ISDB-T/Tb standards with content-checking support for MPEG-2 and H.264/AVC. Optional RF measurement
interfaces provide a powerful and cost-effective solution for monitoring DVB-T transmitter sites or DVB-S/S2 uplinks and
downlinks. An in-depth, real-time MPEG analysis option allows diagnostics to be performed on live broadcast signals without
having to use deferred-time analysis of captured streams.

IPM400A DTV Monitor
The IPM400A DTV Monitor is a powerful solution for remote monitoring of IP video national and regional headends. The
IPM400A simultaneously verifies both IP and TS integrity on all IP Video flows (sessions) on a GbE link. It is ideal for
monitoring networks which carry both Multi-Program Transport Streams (MPTS) or Single-Program Transport Streams
(SPTS), at either constant bit rate (CBR) or variable bit rate (VBR). An in-depth, real-time MPEG analysis option allows
diagnostics to be performed on live payload without having to use deferred-time analysis of captured streams.

QAM400A DTV Monitor
The QAM400A DTV Monitor provides a complete solution for remote real-time monitoring of cable broadcast signals. The
comprehensive QAM RF and SI/PSI and PSIP confidence-monitoring capabilities provide a powerful and cost-effective
solution for monitoring HFC (hybrid fibre-coaxial) cable headends. An in-depth, real-time MPEG analysis option allows
diagnostics to be performed on live ATSC signals without having to use deferred-time analysis of captured streams.

RFM300 DTV Monitor
The RFM300 DTV Monitor provides a complete solution for remote real-time DTV monitoring of ATSC signals. The
comprehensive 8VSB RF and PSIP confidence-monitoring capabilities provide a powerful and cost-effective solution for
monitoring DTV transmitter sites, including contribution and distribution feeds at local and national operation centers for FCC
compliance. An in-depth, real-time MPEG analysis option allows diagnostics to be performed on live ATSC signals without
having to use deferred-time analysis of captured streams.
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VQNet™ Element Management System
VQNet is a Tektronix Video Monitoring EMS that supports all Tektronix IP Video and DTV Monitor probe types to alert,
locate and diagnose video network problems. It is a software product which will run on a server (not Tektronix supplied) to
aggregate and report on the status of broadcast signals measured by up to 500 distributed probes across a video distribution
network, providing alarms, logs, trending and reporting of key performance metrics.

Related Product Documentation
The following table lists the documentation for Tektronix products related to the VQS1000.

Table ii: Related product documentation
Item Tektronix part number Description
MTM400A DTV Monitor Quick Start
User Manual

071-2492-XX English
071-2493-XX Japanese
071-2632-XX German

Provides installation and high-level operational
overviews

IPM400A DTV Monitor Quick Start
User Manual

071-2698-XX Provides installation and high-level operational
overviews

QAM400A DTV Monitor Quick Start
User Manual

071-2784-XX Provides installation and high-level operational
overviews

RFM300 DTV Monitor Quick Start
User Manual

071-2700-XX Provides installation and high-level operational
overviews

MTM400A, IPM400A, QAM400A,
and RFM300 DTV Monitor Read
This First

071-2654-XX Describes late breaking product information and
operational issues

MTM400A, IPM400A, QAM400A,
and RFM300 DTV Monitor
Technical Reference

077-0175-XX Provides in-depth operating information

VQS1000 Quick Start User Manual v
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Installation

Installation
This section includes instructions for installing and opening the VQS1000 software. The section also describes the
networking that may be required for basic operation.

NOTE. Some of the installation instructions require you to use the DTV monitor remote user interface (RUI). If you are
unfamiliar with the RUI, refer to the appropriate manual.

Before Installation
Check that you have received or downloaded all of the standard accessories. All components of the VQS1000 application
are downloaded from the Tektronix Web site (www.tektronix.com/software). This will make sure that you will always receive
the most current release of the application.

System Requirements
The following minimum PC configuration is recommended for installing the VQS1000:

Operating system: Microsoft Windows XP, SP3 or Windows 7

PC processor requirements: Xeon 5500 series (i7 based) quad-core processor or equivalent

Memory: 4 GB RAM minimum

Hard disk space: 250 GB minimum

NOTE. The VQS1000 application will run satisfactorily on a PC with the preceding specifications. However, some of the
more intensive operations will benefit from using a more powerful PC.

NVidia GPU (General Processor Unit) card with hardware video decoder support. For example, the NVidia GeForce
GT240 graphics card.

NOTE. The inclusion of hardware graphics processing reduces the processing overhead of video decoding, allowing
processing at higher bit rates or using a larger processing graticule area.

NOTE. If the card is present, the CUDA acceleration feature is available. Enable the CUDA acceleration decoding check
box in the Advanced Configuration tab to take full advantage of the card’s processing capabilities.

Alternatively, you can install the VQS1000 application on an MTS400 Series MPEG Test System.

If you intend using a Tektronix DTV Monitor as a stream source, the minimum monitor firmware version is Version 4.5.

VQS1000 Quick Start User Manual 1



Installation

Software applications. The third-party software application ‘.NET Framework 3.0’ is required by the VQS1000
application. If it is not already installed on your computer, the VQNet application installer will automatically install this
during the installation process.

Application licensing. The VQS1000 software is enabled on your PC and on the MTS400 Series units by applying
unique Option Key strings using the License Management dialog box; the option key string is unique to the dongle
(software key) that is to be used. Enabling the software can be done as part of the installation procedure. If you have
purchased and downloaded the standalone option, the USB dongle will be supplied separately. (See page 4, Licensing
the VQS1000 Application.)

Installation requirements. You will need the following items:

A PC that meets the system requirements (See page 1, System Requirements.)

VQS1000 installation software (downloaded from www.tektronix.com/software)

Dongle

Option key string

Standard Accessories
The VQS1000 software can be downloaded from the Tektronix Web site (www.tektronix.com/software). The following table
lists the standard accessories that are shipped for the VQS1000 software.

Table 1: Standard accessories
Accessory Tektronix part number
Thank You Letter 001-1532-XX
Option Key Certificate NA
Identification stickers NA
Security dongle

Option USB provides a USB dongle to license a standalone VQS1000
software installation

NA

Option LUD provides no dongle since the VQS1000 software will be installed
on a MTS400 Series product and will use the existing MTS400 Series dongle
for licensing

NA

2 VQS1000 Quick Start User Manual



Installation

Installing the VQS1000 Software
Perform the following steps to install the VQS1000 software. Note that third-party software applications required by the
VQS1000 software will also be installed if required.

1. Download the VQS1000 application installation file from the Tektronix Web site.

a. In Internet Explorer, enter www.tektronix.com in the address bar and select enter.

b. On the Tektronix home page, in the Downloads area, enter the Model Number, VQS1000, and select Software from
the Select Download Type list. Select Go.

c. On the Download Finder page, select the VQS1000 software download entry.

d. On the VQS1000 software download page, check the Version and Release Date, and review the Release Notes and
Installation Instructions.

e. Select Download File.

f. Identify a location for the download on your PC, and allow the file to finish downloading.

2. From the download location, double-click the VQS1000 setup file, VQS1000_setup.exe.

Follow the on-screen instructions to perform the installation.

NOTE. Several message boxes are displayed during the installation process. A reboot of your PC may be required.

If needed, Microsoft .NET Framework will be installed or updated on your PC automatically during the installation process.

3. When the final installation screen is displayed, the installation is complete.

NOTE. Continue with Licensing the VQS1000 Application; (See page 4, Licensing the VQS1000 Application.). This activity
must be completed before you can use the VQS1000 application. If you choose not to license the application at this point,
you will have to do it when you open the application for the first time.

4. In the final VQS1000 installation screen, select the Launch Tektronix VQS1000 check box.

VQS1000 Quick Start User Manual 3



Installation

Licensing the VQS1000 Application
To license your VQS1000 for use on either a PC or an MTS400 Series system, a license key string must be applied to the
instrument after the software has been installed.

Perform the following steps to license the VQS1000 application software:

1. Make sure that the dongle (software key), that you received when you ordered the VQS1000, is mounted in a USB port
in your PC, or that your existing MTS400 dongle (software key), is mounted in the MTS400 instrument, and that your
new license key string is available.

NOTE. If you get a message that your PC does not recognize the dongle hardware, you need to install the DESkey
driver on your PC.

2. Open the VQS1000 License Management dialog box.

a. If you selected the Launch Tektronix VQS1000 check box in the final VQS1000 installation screen, the License
Management dialog box should already be displayed.

b. or, select Start > Tektronix > Tektronix VQS1000 Video Quality Test Suite.

3. Enter the option key string that you received with your dongle in the New Option Key field.

4. Note the options that are now available, and that the option key string that you entered is now displayed in the Existing
Option Key field.
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5. After you close the dialog box, you can continue to use the VQS1000 software.

6. Attach the VQS1000 identification sticker to your PC. You may be asked for your product serial number if you contact
Tektronix for product assistance.

Starting and Closing the VQS1000 Application
Starting the VQS1000 Application from your Desktop
Perform the following steps to start the VQS1000 application:

1. From a computer with the VQS1000 application software installed, select Start > Tektronix > Tektronix VQS1000 Video
Quality Test Suite.

2. To start analyzing a stream, refer to the Application example in this manual, or in the application window, select Help >
Help, and consult the online help to start analyzing a file either offline or in real-time.

Closing the VQS1000 Application
To close the VQS1000 application, select Exit from the File menu.
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Using the Software
This section describes the basics of how to use the software.

Getting Acquainted with the Software
This section provides brief descriptions of the screen display elements. You can modify the size of individual panels by
dragging the borders as required.

Table 2: VQS1000 display elements
Item Element Item Element
1 Title Bar (See page 7.) 5 Trend Graphs (See page 8.)
2 Menu Bar (See page 7.) 6 Video Tests (See page 8.)
3 Toolbar (See page 8.) 7 Source Image (See page 8.)
4 Stream Information (See page 8.) 8 Processed Images (See page 8.)
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Title Bar
The title bar displays the application title and the source file name.

Menu Bar
The Menu bar includes four menus, each containing related options; the menus are titled Analysis, View, Settings, and Help.
Where available, shortcut keys are displayed next to the menu option.

Table 3: Menu bar options
Menu Options Description

File Analysis Select a file for offline analysis
Real-time Analysis Select IP traffic present on your network card for

analysis. Alternatively, you can start analysis from
an associated DTV monitor.

Stream Selection Select an elementary stream for analysis.
Recent Files Displays the names of the most recently opened files.

Analysis menu

Exit Terminates analysis and closes the application.
View menu Dashboard Layout Selecting this option hides/shows the dashboard

panels - Stream Information, Trend Graphs, and
Video Tests. This provides more screen space
for the visual analysis panels - Source view and
Processed Image.

Configuration Opens Configuration dialog box.
Recording Opens the Recording Settings dialog box.
Use Polling When enabled, the VQS1000 will poll services within

an MPTS.

NOTE. Polling is not applicable for offline file
analysis.

Settings menu

Reset All Peak Markers Select this option to reset the peak markers on the
video test meters.

Help Opens the VQS1000 online help window. Access
your area of interest using the navigation pane of the
help window. Context sensitive help is also available
by selecting a screen display element and pressing
F1 key on your keyboard.

License Management Opens the License Management dialog box.

Help

About Tektronix VQS1000 Displays the software version number. You will need
this number if you call Tektronix for technical support.
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Toolbar
The buttons displayed on the Toolbar provide links to set-up dialog boxes used to set up and run the application.

Table 4: Toolbar buttons
Button Description
Open File Select a file for offline analysis.
Real-time Select IP traffic present on your network card for analysis.

Alternatively, you can start analysis from an associated DTV monitor.
Stream Selection Select an elementary stream for analysis.
Configuration Opens configuration dialog box.
Pause/Resume Analysis Select this button to pause or resume analysis.
Record Now Select this button to start recording immediately.

Stream Information
This panel provides a summary of the video stream information, including the codec being used and the current bit rate.

Trend Graphs
This panel shows trend graphs for video measurements. You can select which measurements are displayed, and the
time period over which data is displayed. The following graphs are available: Black Frame, Blockiness, Frozen Frame,
and Video Bit Rate (real-time analysis only).

Video Tests
This panel contains test related meters which give a visual indication of the test status. The following video tests are
available: Black Frame, Blockiness, Frozen Frame, and Video Bit Rate (real-time analysis only).

For each test, thresholds can be set which can generate an alarm. Where a stream is being received from a DTV Monitor,
the alarm state will be passed back and flagged in their respective screen displays.

Event Log
The event log panel records alarm activity that has occurred since the last time that the log was cleared. The log file can
be exported in CSV (comma separated values) format for detailed inspection.

Source Image
This panel displays the source image; the selected video stream. You can select the area of the source image to be
processed and displayed in the processed image panel.

Processed Images
The processed image panels display analyses of the area that you have selected in the source image. The following
processed images can be selected: Motion, Black, Blockiness, and Color.
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Configuring a DTV Monitor for Use with the VQS1000 Software
For the VQS1000 application to work with the DTV Monitor, the VQS1000 player must be set up correctly in the DTV Monitor.

Setting Up the VQS1000 Player in the DTV Monitor
1. Open the DTV Monitor remote user interface (RUI).

2. Select Configuration on the Toolbar to open the Configuration dialog box.

3. In the dialog box, select Preferences > Decode.

4. In the Select Player panel, select the Tektronix VQS1000 player.

CAUTION. If the VQS1000 player is not present in the player list, check that the latest version of the firmware is installed in
the DTV Monitor. The minimum firmware version is Version 4.5. Refer to the DTV Monitor documentation for details of how to
update the firmware. (See page v, Related Product Documentation.)

5. Select OK to enable the VQS1000 player.

Selecting a Stream for Analysis
Use the following steps to set up backhauling of a stream from a DTV Monitor:

1. Open the DTV Monitor Remote User Interface (RUI).

2. Select the Analysis > Programs > Thumbnails tab to display thumbnails of the stream content.

3. Select the Play (►) button below the thumbnail. The VQS1000 application will be opened and display analysis of
the selected stream.

NOTE. If the video backhaul fails, check the presence and status of the firewall on the VQS1000 host PC.
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Application Examples
This section provides the following application examples:

Analyzing video files

Backhauling video from a DTV monitor

Analyzing real-time IP video

Analyzing Video Files
Start Up
1. Ensure that the time and date on the

VQS1000 host PC are set accurately.
This will ensure that the VQS1000
timeline and log statistics are recorded
properly.

2. Ensure that a dongle, with the appropriate
licensing information, is attached to the
host PC.

3. Select Start > Tektronix > Tektronix
VQS1000 Video Quality Test Suite.
Wait for the application to open.

Configuration and Setup
4. Ensure that View > Dashboard Layout

is checked.
This ensures that you can see all of the
panels. These are needed to complete
this example.
If you clear the View > Dashboard
Layout check box, only the two lower
panels will be displayed (source image
and processed image panels). Use
this view when you want to analyze the
stream visually only.

5. Drag the borders of the display panels to
adjust the sizes, as required.

6. In the source image panel, select Reset
Graticule from the right-click context
menu.
This sets the window to default size: that
is, the graticule centered on two thirds of
the standard SD/HD frame.
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7. In the Trend Graphs panel, right-click
and select Time Interval > Last Minute
from the context menu.

8. In the Trend Graphs panel, select
Selected Measurements > Add All.

9. Select Settings > Recording to open
the Recording Settings dialog box.
Make a note of the folder that will be
used for recordings. You can change this
if you want to.

10. Select the Video Triggers Blockiness
check box.

11. Close the dialog box.
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12. Select Settings > Configuration to open
the Configuration dialog box.

13. In the Configuration dialog box, select
the Blockiness tab.

14. Set the Macroblock Size slider to 8.

15. In the Configuration dialog box, select
the Advanced tab.

16. Select Full deinterlacing.
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17. In the Configuration dialog box, select
the File tab.

18. Disable Automatically Repeat
Analysis. This disables looping of the
file.

19. In the Configuration dialog box, select
the Log File tab.

20. Enable Logging.

21. Enter a destination path for log files.

VQS1000 Quick Start User Manual 13



Application Examples

Edit Alarm Parameters
22. In the Video Tests panel, select Edit

Alarm Parameters from the Black Frame
test meter context menu to display the
Edit Alarm Parameters dialog box.

23. In the Consecutive frames panel, select
the Raise alarm check box.

24. Set Raise alarm if value stays above
95% for 30 seconds.

25. In the Event count panel, clear the Raise
alarm check box.

26. Select OK.

27. In the Video Tests panel, select Edit
Alarm Parameters from the Frozen
Frame test meter context menu to display
the Edit Alarm Parameters dialog box.

28. In the Consecutive frames panel, select
the Raise alarm check box.

29. Set Raise alarm if value stays above
97% for 3 seconds.

30. In the Event count panel, select the
Raise alarm check box.

31. Set Raise alarm if value stays
above 90% for at least 10 times in
100 seconds.

32. Select OK.

33. In the Video Tests panel, select Edit
Alarm Parameters from the Blockiness
test meter context menu to display the
Edit Alarm Parameters dialog box.

34. In the Consecutive frames panel, select
the Raise alarm check box.

35. Set Raise alarm if value stays above
95% for 3 seconds.

36. In the Event count panel, select the
Raise alarm check box.

37. Set Raise alarm if value stays above
60% for at least 2 times in 6 seconds.

38. Select OK.
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File Analysis
39. Select Analysis > File Analysis.

40. In the Select a file dialog box, locate and
select a file for analysis.
In this application example, the file
525_02_5M_Sports.trp is used. If
you use a different file, some of the data
displayed will be different.

41. Select Open.

42. In the Stream Information panel, note
that the Resolution is 704 x 480, and the
Scan is Interlaced. In the status bar, the
source bit rate is reported as 2.500 Mbps.
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43. Select the Event Log tab in the Video
Tests panel. Note that any triggered
events are recorded; the recorded file will
be stored in the folder specified in the
Log file configuration settings.

44. Select Export Log to export the event
log to a csv (comma separated value)
file.

45. After about two minutes, use
Windows Explorer to locate and
open a triggered file report. The
file name will be of the format,
VQS1000.<date><time>.xml,
for example,
VQS1000.201005201144.xml.
You can open this file in Microsoft Excel
or similar spreadsheet tool. Each row in
the file represents 60 seconds of event
data. Each row, in addition to the time
and date, contains the minimum, mean,
and maximum values recorded for each
of the video tests.

46. With the cursor in the source image
panel, drag and drop the graticule corner
handles and edges to adjust the area
being displayed in the processed image
panels.
Larger graticule windows require more
intensive processing.
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47. Note that where a measurement exceeds
the set video test thresholds, the LED
icon at the top left of meter will show red.
Normally, when there is no error, it will
display green.

48. Select Analysis > Stream Selection.

49. Expand the Program tree.
Select any of the elementary streams
for display. The analysis of the newly
selected stream will start immediately.

50. Close the Stream Selection panel.
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Analyzing Backhauled Video from a DTV Monitor
This application example describes how to analyze video that is backhauled from a Tektronix DTV monitor such as an
MTM400A, IPM400A, QAM400A, or RFM300. This example uses an MTM400A for illustrative purposes, but you can use
any DTV monitor since the operation is the same for any of the monitors.

CAUTION. Before the DTV monitor will operate with the VQS1000 software, firmware version 4.5 or later must be installed
on the DTV monitor.

The following application assumes that you have already worked through the previous example and have retained the
settings that you made. (See page 10, Analyzing Video Files.) It is also assumed that you are familiar with the basic
operating procedures for a DTV monitor. If necessary, refer to the DTV monitor user documentation. (See Table ii on page v.)

1. Open the MTM400A DTV monitor remote
user interface (RUI).

2. Ensure that the stream is being
monitored by observing the activity.
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3. In the MTM400A RUI, select
Configuration (toolbar) > Preferences
> Decode to display the Decode
configuration dialog box.

4. In the Select Player pane, select the
Tektronix VQS1000 player.
This ensures that when the thumbnail
play button is selected, the VQS1000
application launches.

5. In the Streaming Destination pane, note
the Automatic Port setting and the Local
IP Address (the latter should be the IP
address of your PC).

6. Select OK to close the dialog box.
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7. Select Analysis tab > Programs >
Thumbnails.

8. Identify the program to be analyzed by
the VQS1000 and select the (blue) play
button.

9. The VQS1000 is launched and begins
decoding the program frame by frame.
The IP address of the source MTM400A
is displayed in the VQS1000 status bar.
The Decode Buffer progress indicator, in
the status bar, shows you the state of the
decode buffer as the file is analyzed. If
your PC is unable to process the stream
in real-time, you may see breaks in the
continuity of the stream.

10. If you have set video measurement
thresholds, the LED icons in the Video
Tests panel will turn red when the
threshold is exceeded.
In this example, the frozen frame video
test has exceeded the setting that you
entered, that is Raise alarm if value
stays above 25 for 1 second.

11. You can also see the frozen frame
activity in the trend graph panel.
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Information is fed back to the DTV monitor,
which can be used, as with any other alarm,
for logging, recording, and sending traps or
enabling physical outputs.

12. In the MTM400A, select the Tests tab
and in the navigation pane, expand the
Stream Tests tree until the AV Quality
Tests node is visible.

13. Expand the AV Quality Tests node,
and note that the Video Frozen node is
indicating either an active error (red) or a
that an error has occurred (yellow).

14. Highlight the PID causing the error, and
note that the Event Log records details
of the error.
Remember that when video test
thresholds are exceeded, the events are
recorded in the event log. Also, if you
have set recordings to be made when
video test thresholds are exceeded, the
VQS1000 will be logging and recording
the minimum, mean, and maximum
values in 60 second segments.
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Analyzing Real-time Video Over IP
In this application, you will select a network card and identify a stream for analysis in real-time. You must ensure that
the PC that the VQS1000 software is installed on is connected to an IP switch that is serving multicast or unicast traffic;
consult your network administrator if necessary.

It is assumed that you have worked through the previous two example applications; in particular, the Start Up and
Configuration and Set Up procedures. (See page 10.)

1. Select Start > Tektronix > Tektronix
VQS1000 Video Quality Test Suite.
Wait for the application to open.

2. Select Analysis > Real-time to open the
Real-time Analysis dialog box.

3. Select a Network card from the
drop-down list.

4. Choose either:

to use directed traffic on a designated
UDP port, or

to inspect all traffic present on the
selected network card.

For this example, select the Inspect all
traffic option button.

NOTE. If the video backhaul subsequently
fails, check the presence and status of
any firewall on the VQS1000 host PC. The
firewall should allow communication with the
VQS1000.

5. Select Analyze to close the Real-time
Analysis dialog box and start the
analysis.

6. Initially, Waiting for Data is displayed
in the left side of the status bar. When
there is enough data in the Decode
Buffer, the status bar message changes
to Frames/sec and analysis begins.
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7. Select Analysis > Stream Selection to
open the Stream Selection dialog box.
The Stream Selection dialog box displays
all of the traffic available to the selected
network card. You may need to wait for a
short time until all of the traffic details are
available to display.

8. Expand each of the program nodes to
see all of the video streams that are
available.

9. Select a stream. Analysis starts almost
immediately.

10. Close the Stream Selection dialog box.

11. Continue with the analysis and
measurements as described in the
previous application examples. (See
page 10.)
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